summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12019-02-05 02:40:07 +0800
committerChocobo12019-02-05 02:42:16 +0800
commitd9abd4d1fe75edba1377d750a5840df84d95621c (patch)
tree303e788c48fee910fc8417a73d7d2b80445fe62c /PKGBUILD
downloadaur-d9abd4d1fe75edba1377d750a5840df84d95621c.tar.gz
newpkg: qt5-quickcontrols2-git 5.12.1.r25.g1a89fbc5-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac6a483ef7a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=qt5-quickcontrols2-git
+pkgver=5.12.1.r25.g1a89fbc5
+pkgrel=1
+pkgdesc="Qt5 Quick Controls module"
+arch=('i686' 'x86_64')
+url="https://www.qt.io/"
+license=('FDL' 'GPL' 'LGPL')
+depends=('qt5-declarative')
+makedepends=('git')
+optdepends=('qt5-graphicaleffects: for the Material style')
+provides=('qt5-quickcontrols2')
+conflicts=('qt5-quickcontrols2')
+source=("git+https://code.qt.io/qt/qtquickcontrols2.git#branch=dev")
+sha256sums=('SKIP')
+
+
+prepare() {
+ cd "$srcdir"
+
+ mkdir -p "_build"
+}
+
+pkgver() {
+ cd "qtquickcontrols2"
+
+ _tag=$(git tag -l --sort -v:refname | sed -n '1,1{s/v//p}')
+ _rev=$(git rev-list --count v$_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash"
+}
+
+build() {
+ cd "_build"
+
+ qmake ../qtquickcontrols2
+ make
+}
+
+package() {
+ cd "_build"
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+}