summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSkycoder422018-02-16 20:47:30 +0100
committerSkycoder422018-02-16 20:47:30 +0100
commit4f296e3786ab16f79d59c47888934e5088cb6201 (patch)
tree5c531aee9919c96b5fab331f3d06d21ca71925e2 /PKGBUILD
parentdb7e9ead5daf442ed4b1cae11f9c829777844076 (diff)
downloadaur-4f296e3786ab16f79d59c47888934e5088cb6201.tar.gz
updated to 1.2.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 25 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d9ea9f28f2c..149ab4d5a2ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
# Maintainer: Felix Barz <skycoder42.de@gmx.de>
-pkgname=qt5-restclient
-pkgver=1.2.5
+pkgbase=qt5-restclient
+pkgname=(qt5-restclient qt5-restclient-doc)
+group=qt5-restclient-full
+pkgver=1.2.6
pkgrel=1
pkgdesc="A library for generic JSON-based REST-APIs, with a mechanism to map JSON to Qt objects"
arch=('i686' 'x86_64')
url="https://github.com/Skycoder42/QtRestClient"
license=('BSD')
-depends=('qt5-base' 'qt5-jsonserializer>=2.1.0')
-makedepends=('git' 'qt5-tools')
+depends=('qt5-base' 'qt5-jsonserializer>=3.1.0')
+makedepends=('git' 'qt5-tools' 'python' 'doxygen' 'graphviz')
optdepends=("repkg: Automatically rebuild the package on dependency updates")
_pkgfqn=$pkgname-$pkgver
source=("$_pkgfqn::git+https://github.com/Skycoder42/QtRestClient.git#tag=$pkgver"
@@ -25,11 +27,17 @@ build() {
qmake "../$_pkgfqn/"
make qmake_all
make
+ make lrelease
+ make doxygen
}
-package() {
+package_qt5-restclient() {
cd build
+ cd src
make INSTALL_ROOT="$pkgdir" install
+ cd ../tools
+ make INSTALL_ROOT="$pkgdir" install
+ cd ..
# Drop QMAKE_PRL_BUILD_DIR because reference the build dir
find "$pkgdir/usr/lib" -type f -name '*.prl' \
@@ -38,3 +46,15 @@ package() {
install -D -m644 "../$_pkgfqn/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -D -m644 "../${pkgname}.rule" "$pkgdir/etc/repkg/rules/${pkgname}.rule"
}
+
+package_qt5-restclient-doc() {
+ depends=('qt5-restclient')
+ optdepends=()
+
+ cd build/doc
+ make INSTALL_ROOT="$pkgdir" install
+
+ # DROP file paths from doc tags
+ find "$pkgdir/usr/share/doc/qt" -type f -name '*.tags' \
+ -exec sed -i -e 's:<path>[^<]*<\/path>:<path>/usr/include/qt/QtRestClient</path>:g' {} \;
+}