summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSkycoder422018-10-19 23:08:40 +0200
committerSkycoder422018-10-19 23:08:40 +0200
commitb9c247f81e6e65fb4060c666063f61f853e887e0 (patch)
tree5f0f6cc1eb05ec27fb177bebd672e18dedfae000 /PKGBUILD
parent1cf4b3428ad5be855f5829d6c97d3c2d99906b31 (diff)
downloadaur-b9c247f81e6e65fb4060c666063f61f853e887e0.tar.gz
updated to 2.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b1e27cb8bd22..d863d2c454f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
pkgbase=qt5-restclient
pkgname=(qt5-restclient qt5-restclient-doc)
group=qt5-restclient-full
-pkgver=2.0.0
+pkgver=2.1.0
pkgrel=1
pkgdesc="A library for generic JSON-based REST-APIs, with a mechanism to map JSON to Qt objects"
arch=('i686' 'x86_64')
url="https://github.com/Skycoder42/QtRestClient"
license=('BSD')
depends=('qt5-base' 'qt5-jsonserializer>=3.1.0')
-makedepends=('git' 'qt5-tools' 'python' 'doxygen' 'graphviz')
+makedepends=('git' 'qt5-tools' 'qt5-declarative' 'qpmx-qpmsource' 'python' 'doxygen' 'graphviz')
optdepends=("repkg: Automatically rebuild the package on dependency updates")
_pkgfqn=$pkgname-$pkgver
source=("$_pkgfqn::git+https://github.com/Skycoder42/QtRestClient.git#tag=$pkgver"
"$pkgname.rule")
sha256sums=('SKIP'
- '6029d42b05d32d99a6e673e5a7c95ac657e6258f88835f8aff05bde7535e543b')
+ '13f2e499671cb094ff244946b733a8e6898152fe60c77cb93bef1e1a19ffbd0e')
prepare() {
mkdir -p build
@@ -31,6 +31,11 @@ build() {
make doxygen
}
+check() {
+ cd build
+ make run-tests
+}
+
package_qt5-restclient() {
cd build
cd src
@@ -46,7 +51,7 @@ package_qt5-restclient() {
install -D -m644 "../$_pkgfqn/qbs/Qt/restbuilder/module.qbs" "$pkgdir/usr/share/qbs/modules/Qt/restbuilder/module.qbs"
install -D -m644 "../$_pkgfqn/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -D -m644 "../${pkgname}.rule" "$pkgdir/etc/repkg/rules/${pkgname}.rule"
+ install -D -m644 "../${pkgname}.rule" "$pkgdir/etc/repkg/rules/system/${pkgname}.rule"
}
package_qt5-restclient-doc() {
@@ -59,4 +64,7 @@ package_qt5-restclient-doc() {
# DROP file paths from doc tags
find "$pkgdir/usr/share/doc/qt" -type f -name '*.tags' \
-exec sed -i -e 's:<path>[^<]*<\/path>:<path>/usr/include/qt/QtRestClient</path>:g' {} \;
+
+ # install manpages
+ install -Dm644 -t "$pkgdir/usr/share/man/man3" man/man3/*.3
}