summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSwift Geek2013-06-21 16:00:18 +0000
committerThomas Dziedzic2013-06-21 16:00:18 +0000
commitcc86c3e74ee03ac43d3f1130c6a16553549cdc08 (patch)
tree5b0e2374060397e6c922058906c257b5e2180072 /PKGBUILD
parent088f40b1d03f753d1f6caeb1ba2c969d501bfa8c (diff)
downloadaur-cc86c3e74ee03ac43d3f1130c6a16553549cdc08.tar.gz
Import from pkgbuild.com service
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 13 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 49f17cfaab65..6408f797f20c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
pkgname=qt5-wayland-git
-pkgver=20130521
+pkgver=0.0.0
pkgrel=1
pkgdesc="A cross-platform application and UI framework (QtCompositor, Wayland QPA plugins)"
groups=('qt' 'qt5')
@@ -13,29 +13,27 @@ replaces=('qt5-qtwayland-git')
provides=('qt5-wayland')
conflicts=('qt5-wayland')
makedepends=('gcc' 'git')
-
#_gitroot="git://gitorious.org/qt/qtwayland.git"
_gitroot="git://github.com/plfiorini/qtwayland.git"
-_gitname=qt5-qtwayland
#_gitbranch=master
_gitbranch=hawaii-stable
+_gitname="qt5-wayland"
+source=(${_gitname}::${_gitroot}#branch=${_gitbranch})
+md5sums=('SKIP')
-build() {
- if [ ! -d "${_gitname}" ]; then
- git clone -b ${_gitbranch} --depth 1 ${_gitroot} ${_gitname} && cd ${_gitname}
- else
- cd ${_gitname} && git reset --hard && git pull origin && git clean -dfx
- fi
-
- msg "GIT checkout done."
+pkgver() {
+ cd ${srcdir}/${_gitname}
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
- #qmake CONFIG+=wayland-compositor
- qmake
+build() {
+ cd ${srcdir}/${_gitname}
+ qmake CONFIG+=wayland-compositor
+ #qmake
make
}
package() {
- cd "${_gitname}"
-
+ cd ${srcdir}/${_gitname}
make INSTALL_ROOT="${pkgdir}" install
}