summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSolomon Choina2021-06-23 21:13:50 -0400
committerSolomon Choina2021-06-23 21:13:50 -0400
commit0c0292fb3fa24cffddeea09852687231f01f4deb (patch)
tree4660d562558c30cfee812b53852bf1460e923b2f /PKGBUILD
parent03e19028ed49ad582f9f9ad34a6a94105d02b359 (diff)
downloadaur-0c0292fb3fa24cffddeea09852687231f01f4deb.tar.gz
updating the pkgbuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f30ff3baca86..d6ef8fcb9edb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=qtcurve-git
_realver=1.8.18
-pkgver=1.8.18.293.ga249871e
+pkgver=1.9.0.rc1.75.gbe78a85b
pkgrel=1
pkgdesc='A configurable set of widget styles for KDE and Gtk.'
arch=('i686' 'x86_64')
@@ -10,8 +10,8 @@ url="https://github.com/QtCurve/qtcurve"
license=('GPL')
groups=('qtcurve')
depends=('qt5-base' 'qt5-svg' 'libxcb' 'qt5-x11extras'
- 'gtk2' 'libx11' 'gcc-libs')
-makedepends=('cmake' 'automoc4' 'git')
+ 'gtk2' 'libx11' 'gcc-libs' 'qt4' 'frameworkintegration')
+makedepends=('cmake' 'git' 'extra-cmake-modules' 'kio' 'kconfig')
provides=(
"qtcurve-utils=${_realver}"
"qtcurve-gtk2=${_realver}"
@@ -26,7 +26,7 @@ provides=(
conflicts=("qtcurve-kde4" "qtcurve-qt4"
"qtcurve-qt5" "qtcurve-gtk2" "qtcurve-utils")
options=('!debug' 'strip')
-source=(git://anongit.kde.org/qtcurve.git)
+source=("git+https://invent.kde.org/system/qtcurve.git")
_gitname=qtcurve
pkgver() {
@@ -43,11 +43,7 @@ build() {
cmake .. \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DQT_QMAKE_EXECUTABLE=qmake-qt5 \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DQTC_KDE4_PREFIX=/usr \
- -DQTC_QT4_ENABLE_KDE:BOOL="0" \
- -DQTC_QT4_STYLE_SUPPORT:BOOL="0"
+ -DCMAKE_INSTALL_PREFIX=/usr
make
}