summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrainwreckedTech2020-09-20 09:58:16 -0400
committerBrainwreckedTech2020-09-20 09:58:16 -0400
commit1e44a8cd74860aa77dd49f4819ce0d37e12b58f8 (patch)
treebcf623d6179aafcd98e31b3dbc3952afd547035a /PKGBUILD
parenteeebc3cec663bdb5f5b9ef4716cd53024cd55bc5 (diff)
downloadaur-1e44a8cd74860aa77dd49f4819ce0d37e12b58f8.tar.gz
Added QPainterPath Patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 78f13711609d..7c96fafaf9fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
_pkgname=qtfm
pkgname=$_pkgname-git
-pkgver=2019.08.23
+pkgver=2019.10.14
pkgrel=1
pkgdesc="A lightweight file manager (git version)"
arch=('i686' 'x86_64')
@@ -20,14 +20,19 @@ license=('GPL')
depends=('qt5-base' 'desktop-file-utils' 'ffmpeg' 'hicolor-icon-theme' 'imagemagick')
provides=('qtfm')
conflicts=('qtfm')
-source=('qtfm::git+https://github.com/rodlie/qtfm.git#branch=master')
-md5sums=('SKIP')
+source=('qtfm::git+https://github.com/rodlie/qtfm.git#branch=master' 'qt-5.15+gentoo.patch')
+sha256sums=('SKIP' '34271a58f32eeed01ab2db408505e8a1cef20f4a60a372ba78c5607b404eb010')
pkgver() {
cd "$_pkgname"
git log -1 --format=%ci | sed 's/[ :-]/./g' | cut -d. -f1-3
}
+prepare() {
+ cd "${pkgname%-git}"
+ patch -Np1 < "$srcdir"/qt-5.15+gentoo.patch
+}
+
build() {
cd $_pkgname
[[ -d build ]] || mkdir build