summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrainwreckedTech2023-01-24 03:46:27 -0500
committerBrainwreckedTech2023-01-24 03:46:27 -0500
commit5476adec784604213de13b33bb29444e4c46e010 (patch)
tree46397bc223589499677651954ba5e5774cff5748 /PKGBUILD
parent1b97243c67dd5ff414ba5a3b3ac367449efc9e50 (diff)
downloadaur-5476adec784604213de13b33bb29444e4c46e010.tar.gz
Updated for latest commit as of Nov 01 2022
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c96fafaf9fa..3df00854c9b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,33 +11,36 @@
_pkgname=qtfm
pkgname=$_pkgname-git
-pkgver=2019.10.14
+pkgver=2022.11.01
pkgrel=1
pkgdesc="A lightweight file manager (git version)"
arch=('i686' 'x86_64')
url="https://github.com/rodlie/qtfm/releases"
license=('GPL')
-depends=('qt5-base' 'desktop-file-utils' 'ffmpeg' 'hicolor-icon-theme' 'imagemagick')
+#depends=('qt5-base' 'desktop-file-utils' 'ffmpeg' 'hicolor-icon-theme' 'imagemagick')
+depends=('qt5-base' 'desktop-file-utils' 'hicolor-icon-theme' 'imagemagick')
provides=('qtfm')
conflicts=('qtfm')
-source=('qtfm::git+https://github.com/rodlie/qtfm.git#branch=master' 'qt-5.15+gentoo.patch')
-sha256sums=('SKIP' '34271a58f32eeed01ab2db408505e8a1cef20f4a60a372ba78c5607b404eb010')
+source=('qtfm::git+https://github.com/rodlie/qtfm.git#branch=master')
+sha256sums=('SKIP')
pkgver() {
cd "$_pkgname"
git log -1 --format=%ci | sed 's/[ :-]/./g' | cut -d. -f1-3
}
-prepare() {
- cd "${pkgname%-git}"
- patch -Np1 < "$srcdir"/qt-5.15+gentoo.patch
-}
+#prepare() {
+# This is left here as a note in case a patch is ever needed again.
+# cd "${pkgname%-git}"
+# patch -Np1 < "$srcdir"/patch.patch
+#}
build() {
cd $_pkgname
[[ -d build ]] || mkdir build
cd build
- qmake CONFIG+=release CONFIG+=with_ffmpeg CONFIG+=with_magick PREFIX=/usr ..
+# CONFIG+=with_ffmpeg is currently broken due to deprecations
+ qmake CONFIG+=release CONFIG+=with_magick PREFIX=/usr ..
make
}