summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorelParaguayo2022-09-22 21:22:13 +0100
committerelParaguayo2022-09-22 21:22:13 +0100
commit041ded5ed0387a7523a9a7aa9c3a1d9406187311 (patch)
treeaebda53b059efe1b0bf26033f15c3b5e946ddfa1 /PKGBUILD
downloadaur-041ded5ed0387a7523a9a7aa9c3a1d9406187311.tar.gz
v0.22.1 release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd3645b966e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: elParaguayo <elparaguayocode at gmail dot com>
+pkgname=qtile-extras
+pkgver=0.22.1
+pkgrel=1
+provides=("$pkgname")
+conflicts=("$pkgname")
+pkgdesc="Unofficial mods for qtile. Tagged release to match stable qtile releases."
+url="https://github.com/elparaguayo/qtile-extras.git"
+arch=("any")
+license=("MIT")
+depends=("python" "qtile")
+makedepends=("git" "python-setuptools-scm")
+optdepends=(
+ "python-requests: various widgets"
+ "python-iwlib: wifi icon widget"
+ "python-dbus-next: various widgets"
+)
+source=(git+https://github.com/elparaguayo/qtile-extras#tag=v$pkgver?signed)
+md5sums=("SKIP")
+validpgpkeys=(
+ 'A6BAA1E17D2664ADB97B2C6F58A9AA7C86727DF7' # elParaguayo <elparaguayocode at gmail dot com>
+)
+
+
+package()
+{
+ cd "$pkgname"
+ python setup.py install --root="$pkgdir"
+
+ install -vDm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -vDm 644 CHANGELOG -t "$pkgdir/usr/share/doc/$pkgname/"
+}