summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDX372017-03-01 22:24:06 +0700
committerDX372017-03-01 22:24:06 +0700
commit4ca6333cfeac082f43305986bcd8e5f59687115f (patch)
tree141e79ca08af4e3364f5b0b3a1037e0cc5b8f725 /PKGBUILD
parentfcda5ef339238f2492c91b0d857c99284b42a627 (diff)
downloadaur-4ca6333cfeac082f43305986bcd8e5f59687115f.tar.gz
Update version, switch to CMake, change repo to upstream
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 486c6a32f500..a2df91f1d78d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
-# Maintainer: Jiachen Yang <farseerfc@gmail.com>
+# Maintainer: Maxim Kurnosenko <asusx2@mail.ru>
+# Contributor: Jiachen Yang <farseerfc@gmail.com>
# Contributor: HÃ¥vard Pettersson <mail@haavard.me>
# Contributor: Kevin MacMartin <prurigro at gmail dot com>
_pkgname=qtox
pkgname=qtox-git
-pkgver=1.7.0.r20.gd4ac13db
+pkgver=1.8.1.r93.gffd7d0e9
pkgrel=1
pkgdesc='Powerful Tox client written in C++/Qt that follows the Tox design guidelines.'
-arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
+arch=('i686' 'x86_64')
url='https://github.com/tux3/qTox'
license=('GPL3')
depends=('desktop-file-utils'
@@ -19,10 +20,10 @@ depends=('desktop-file-utils'
'qt5-svg'
'sqlcipher'
'toxcore>=1:0.1.0')
-makedepends=('git' 'qt5-tools')
+makedepends=('git' 'cmake' 'qt5-tools')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$_pkgname::git+https://github.com/tux3/qTox.git")
+source=("$_pkgname::git+https://github.com/qTox/qTox.git")
sha512sums=('SKIP')
pkgver() {
@@ -30,15 +31,19 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
+prepare() {
cd $_pkgname
install -d build
cd build
- qmake-qt5 ENABLE_SYSTRAY_UNITY_BACKEND=NO CONFIG+=silent ..
- make
+ cmake .. -DCMAKE_INSTALL_PREFIX="/usr"
+}
+
+build() {
+ cd $_pkgname/build
+ make $MAKEFLAGS
}
package() {
cd $_pkgname/build
- make INSTALL_ROOT="$pkgdir" install
+ make DESTDIR="$pkgdir" install
}