summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGimmeapill2017-01-27 21:06:23 +0100
committerGimmeapill2017-01-27 21:06:23 +0100
commitbd6a07ff3874d0b8b76c0d485d667cc6ad0dc0a8 (patch)
tree2af31141a20129977c3e612b94ac0729c1a96d0c /PKGBUILD
parentc629c54e433a6bb23de17bc94c49e085f386da13 (diff)
downloadaur-bd6a07ff3874d0b8b76c0d485d667cc6ad0dc0a8.tar.gz
streamlining a bit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f8c19031607f..8f55587f061e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,37 +3,36 @@
# Contributor: speps <speps at aur dot archlinux dot org>
# Contributor: Philipp Überbacher <hollunder at gmx dot at>
-_pkgbasename=qtractor
-pkgname=${_pkgbasename}-git
-pkgver=0.8.0.r0.gca80cfb
+pkgname=qtractor-git
+pkgver=0.8.0.r47.g700bfa8a
pkgrel=1
pkgdesc="Audio/MIDI multitrack sequencer"
arch=('i686' 'x86_64')
url="http://qtractor.sourceforge.net/"
license=('GPL')
-depends=('qt5-x11extras' 'gtk2' 'suil' 'lilv' 'libmad' 'liblo' 'rubberband')
+depends=(liblo rubberband lilv qt5-x11extras gcc-libs-multilib gtk2 suil libmad)
makedepends=('qt5-tools' 'ladspa' 'dssi')
optdepends=('dssi-vst: win32 VST support')
-provides=("${_pkgbasename}")
-conflicts=("${_pkgbasename}")
-source=("${_pkgbasename}::git://github.com/rncbc/qtractor.git")
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=("${pkgname%-*}"::"git://github.com/rncbc/qtractor.git")
md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgbasename}"
+ cd "${srcdir}/${pkgname%-*}"
# cutting off the 'qtractor_' prefix present in the git tag + remaining underscores (ugly but gets the job done).
git describe --long | sed 's/^qtractor_//;s/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/\_/./g'
}
build() {
- cd "${srcdir}/${_pkgbasename}"
+ cd "${srcdir}/${pkgname%-*}"
make -f Makefile.git
./configure --prefix=/usr
make
}
package() {
- cd "${srcdir}/${_pkgbasename}"
+ cd "${srcdir}/${pkgname%-*}"
make DESTDIR="${pkgdir}" install
}