summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrey Vihrov2016-03-19 21:54:56 +0200
committerAndrey Vihrov2016-03-19 21:54:56 +0200
commita68d24a5915ef363bb8a88afb64c8681dd5ed924 (patch)
tree8325061ba4a7b31088777c4a653894f557819cfb /PKGBUILD
parente2a01e077764907abfc33e2e67ce7fe00886c5ae (diff)
downloadaur-a68d24a5915ef363bb8a88afb64c8681dd5ed924.tar.gz
Do not rename .txt files to .txt.cfg — ioquake3 seems to handle them just fine (tested with fs_debug 1)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a417f2c8f890..d5e1e319c08c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,28 @@
pkgname=quake3-edawn
pkgver=1.4.1
-pkgrel=1
+pkgrel=2
pkgdesc="A Quake III Arena mod with numerous improvements"
arch=('any')
url="http://edawn-mod.org/"
license=('custom')
depends=('quake3')
-source=("http://edawn-mod.org/binaries/edawn-$pkgver-1.zip")
+source=("http://edawn-mod.org/binaries/edawn-${pkgver}-1.zip")
sha256sums=('a6a232f64fcfd3f6387d809b8a7912d6095b6dcd39cc6572407a54c96ab68a27')
package() {
- # Engines other than quake3e may have problems loading files
- # without the .cfg extension
+ # Non-modified Quake 3 engines may have problems loading
+ # files with unusual extensions
cd edawn
- for f in {bans,crontab,motd,rotation,voteconf}.txt maps/*.{add,set} ; do
+ for f in maps/*.{add,set}; do
mv "$f" "$f.cfg"
done
- cd "$srcdir"
- mkdir -p "$pkgdir/opt/quake3"
- cp -dR edawn "$pkgdir/opt/quake3"
+ cd "${srcdir}"
+ mkdir -p "${pkgdir}/opt/quake3"
+ cp -dR edawn "${pkgdir}/opt/quake3"
- install -D -m 644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m 644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim:set ts=2 sw=2 et: