summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrey Vihrov2015-06-14 10:30:47 +0300
committerAndrey Vihrov2015-06-14 10:30:47 +0300
commite5b1bc98c3fb42a254b9cdc779a7c647a81fc8f6 (patch)
treea4f532cd12d3cd0b7aff7688b9ed1a1061678203 /PKGBUILD
downloadaur-e5b1bc98c3fb42a254b9cdc779a7c647a81fc8f6.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6e6e1043027
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Andrey Vihrov <andrey.vihrov at gmail.com>
+
+pkgname=quake3-edawn
+pkgver=1.4
+pkgrel=1
+pkgdesc="A Quake III Arena mod with numerous improvements"
+arch=('any')
+url="http://edawn-mod.org/"
+license=('unknown')
+depends=('quake3')
+source=("http://edawn-mod.org/binaries/edawn-$pkgver-1.zip")
+sha256sums=('c72bcc13fd5f887c59afd42995fb2f6091b16ac4c4f4b41b9745aaa018fe4d34')
+
+package() {
+ # Engines other than quake3e may have problems loading files
+ # without the .cfg extension
+ cd edawn
+ for f in {bans,crontab,motd,rotation,voteconf}.txt maps/*.{add,set} ; do
+ mv "$f" "$f.cfg"
+ done
+
+ cd "$srcdir"
+ mkdir -p "$pkgdir/opt/quake3"
+ cp -dR edawn "$pkgdir/opt/quake3"
+}
+
+# vim:set ts=2 sw=2 et: