summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSlashbunny2009-08-12 22:17:38 -0400
committerSlashbunny2009-08-12 22:17:38 -0400
commit50cddfbd46a238a027757975513521751e2f2ea9 (patch)
tree6857da07833a1ea5b5ce4c63174c95a88dddb6e5 /PKGBUILD
downloadaur-50cddfbd46a238a027757975513521751e2f2ea9.tar.gz
Initial commit of personal PKGBUILDs for Arch Linux
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e055bb885551
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributor: Travis Nickles <ryoohki7@yahoo.com>
+# Contributor: Slash <demodevil5 AT yahoo DOT com>
+
+pkgname=quake3-stereoquake
+pkgver=1
+pkgrel=1
+pkgdesc="Stereogram mod for Quake 3"
+url="http://stereoquake.planetquake.gamespy.com/"
+license=('custom')
+arch=('i686' 'x86_64')
+depends=('quake3')
+makedepends=('unzip')
+conflicts=('stereoquake')
+replaces=('stereoquake')
+source=("quake3-stereoquake.desktop" "quake3-stereoquake.launcher" \
+"http://games.mirrors.tds.net/pub/planetquake3/modifications/stereoquake.zip")
+md5sums=('bd4e5df7a961aab5154ee3143c73de7d'
+ '665b50e9ede2873224f2ebb8020c84b3'
+ '3bd59942350bfc8f0ca306cb86481ffb')
+
+build() {
+ cd $startdir/src
+
+ # Create Destination Directories
+ install -d $startdir/pkg/opt/quake3/
+
+ # Copy Game Data
+ cp -r $startdir/src/stereoquake \
+ $startdir/pkg/opt/quake3
+
+ # Install Launcher
+ install -D -m 755 $startdir/src/quake3-stereoquake.launcher \
+ $startdir/pkg/usr/bin/stereoquake
+
+ # Install Desktop File
+ install -D -m 644 $startdir/src/quake3-stereoquake.desktop \
+ $startdir/pkg/usr/share/applications/quake3-stereoquake.desktop
+}