summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederic Bezies2015-07-08 15:13:46 +0200
committerFrederic Bezies2015-07-08 15:13:46 +0200
commit99b17c51b0438b921315fa02f8502135818a443e (patch)
treeb460b9b1e3e6fc67327a20fae6b882fdd4f7e026 /PKGBUILD
downloadaur-99b17c51b0438b921315fa02f8502135818a443e.tar.gz
initial update on AUR4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..824f19370186
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: qs9rx < that nick at enjoys döt it>
+# Contributor: Christoph Zeiler <rabyte*gmail> (the fitzquake PKGBUILD was a base)
+pkgname=quakespasm-svn
+pkgver=1234
+pkgrel=1
+pkgdesc="A modern Quake 1 engine. Forked from Fitzquake and improved in many ways such as Vorbis/MP3 support for music."
+arch=('i686' 'x86_64')
+url="http://quakespasm.sourceforge.net"
+license=('GPL2')
+depends=('libvorbis' 'libmad' 'sdl')
+makedepends=('subversion')
+install=$pkgname.install
+md5sums=('SKIP')
+
+source=('svn://svn.code.sf.net/p/quakespasm/code/trunk/quakespasm')
+
+pkgver() {
+ cd "$srcdir/quakespasm"
+ svnversion
+}
+
+build() {
+ cd "$srcdir/quakespasm/Quake/"
+ msg "Starting make..."
+ make DO_USERDIRS=1
+}
+
+package() {
+ cd "$srcdir/quakespasm/Quake/"
+ install -Dm755 quakespasm "$pkgdir"/usr/bin/$pkgname
+}