summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2021-01-25 22:04:12 -0500
committerGuillaume Horel2021-01-25 22:04:12 -0500
commitbe1e5850de92c20bb522ae940a2153d488cd572e (patch)
treeb86225063f8ba223868faf064a567c4000ce8de0 /PKGBUILD
parent85a6d37ec70bcda06366efcc07f2436e297f24a3 (diff)
downloadaur-be1e5850de92c20bb522ae940a2153d488cd572e.tar.gz
bump to 1.21
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1543148170cb..c32921f7e376 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,21 +6,22 @@
pkgname=quantlib
_pkgname=QuantLib
-pkgver=1.20
+pkgver=1.21
pkgrel=1
pkgdesc="A free/open-source library for quantitative finance."
arch=('x86_64')
url="http://quantlib.org"
license=('BSD')
options=(!libtool)
-depends=('boost-libs' 'sh')
+depends=('boost-libs')
makedepends=('make' 'boost' 'gcc')
source=("Quantlib-$pkgver.tar.gz::https://bintray.com/quantlib/releases/download_file?file_path=$_pkgname-$pkgver.tar.gz")
-sha256sums=('af51fe73b88be67536aca68ce8aaa30f523a95cc369652a6071d66beef8708ff')
+sha256sums=('3d3296fb13f822de6b980692604e2b1ba0d1b45e0e32d67d80b4cc9725b87d1b')
build() {
cd "$srcdir/$_pkgname-$pkgver"/
- ./autogen.sh
+ autoupdate acinclude.m4 configure.ac
+ autoreconf
./configure --prefix=/usr --enable-intraday --enable-openmp --disable-static --enable-std-classes --enable-std-function
make
}