summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDanny Dutton2016-03-14 10:37:11 -0400
committerDanny Dutton2016-03-14 10:37:11 -0400
commit25fffe807ba8e16e0cb7a43a76e01c58256f46e9 (patch)
tree4601c2391f239053be06de98f015916d1fb1fddb /PKGBUILD
parentaa5094bc6dac0d241d6cd0f116a332832bb56095 (diff)
downloadaur-25fffe807ba8e16e0cb7a43a76e01c58256f46e9.tar.gz
Updated Quartus version and added new lib32-freetype2 link
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 54fbafc9dcc6..ac12b40c3a49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Matthias Blaicher <matthias at blaicher dot com>
+# Co-Maintainer: Danny Dutton <duttondj@vt.edu>
#
# NOTE: If you plan on using the usbblaster make sure you are member of the plugdev group.
# NOTE: Altera has dramatically changed their packing in regards to version 12. This
# PKGBUILD will install the full Altera suite now. Be aware that the space requirement
-# is around 13GB.
+# is around 14GB.
#
pkgname=quartus-free
-pkgver=15.0.0.145
-pkgrel=2
-pkgdesc="Quartus II Web Edition design software for Altera FPGA's"
+pkgver=15.1.0.185
+pkgrel=1
+pkgdesc="Quartus Prime Lite Edition design software for Altera FPGA's"
arch=('i686' 'x86_64')
-url="https://dl.altera.com/?edition=web"
+url="https://dl.altera.com/?edition=lite"
license=('custom')
_build_nr=$(echo ${pkgver} | cut -d '.' -f4)
@@ -42,10 +43,10 @@ fi
makedepends=('bash')
-source=("http://download.altera.com/akdlm/software/acdsinst/${pkgver%.*.*}/${_build_nr}/ib_tar/Quartus-web-${pkgver}-linux.tar"
- "http://seblu.net/a/arm/2013/10/11/multilib/os/x86_64/lib32-freetype2-2.5.0.1-1-x86_64.pkg.tar.xz" # Used for a freetype bugfix HACK
+source=("http://download.altera.com/akdlm/software/acdsinst/${pkgver%.*.*}/${_build_nr}/ib_tar/Quartus-lite-${pkgver}-linux.tar"
+ "http://gaming.jhu.edu/mirror/archlinux/multilib/os/x86_64/lib32-freetype2-2.5.0.1-1-x86_64.pkg.tar.xz" # Used for a freetype bugfix HACK
"quartus.sh" "quartus.desktop" "51-usbblaster.rules" "quartus.install" "modelsim-ase.desktop")
-md5sums=('6bbe995747baf100d7f5bc04246971d7'
+md5sums=('EF0D9EB90E24338AD31864D3069151B0'
'd3b3b7cdf874b6dd0b60c40d84dd9128'
'067c444cae7fe31d3608245712b43ce8'
'32b17cb8b992fc2dccd33d87f0dcd8ce'
@@ -94,4 +95,4 @@ package() {
install -D -m644 modelsim-ase.desktop "${pkgdir}/usr/share/applications/modelsim-ase.desktop"
}
-# vim:set ts=2 sw=2 et: \ No newline at end of file
+# vim:set ts=2 sw=2 et: