summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDoug Newgard2024-03-12 20:16:52 -0500
committerDoug Newgard2024-03-12 20:16:52 -0500
commit2a4a5ad48db4020431e52d549dfdfc18869b8af8 (patch)
tree3a94d0aef334e86bcf9a4da6035f827397928105 /PKGBUILD
parent1a1b543d77ceb799dc745199b55df1f6bf52b836 (diff)
downloadaur-quasselgrep-git.tar.gz
Add patches from PRs for critical functionality
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 16 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ca5f03a9c636..cc5e2919c7f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,22 @@
_pkgname=quasselgrep
pkgname=$_pkgname-git
pkgver=r95.g9b6b0bc
-pkgrel=3
+pkgrel=4
pkgdesc='Tool for searching quassel logs from the commandline'
arch=('any')
url='https://github.com/fish-face/quasselgrep'
-license=('GPL')
-depends=('python' 'python-setuptools' 'python-dateutil' 'python-future' 'python-pycryptodome')
+license=('GPL-2.0-or-later')
+depends=('python' 'python-setuptools' 'python-dateutil' 'python-pycryptodome')
makedepends=('git')
optdepends=('python-psycopg2: Connect to postgres databases')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
-source=('git+https://github.com/fish-face/quasselgrep.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/fish-face/quasselgrep.git'
+ 'quasselgrep-timestamps.patch::https://patch-diff.githubusercontent.com/raw/fish-face/quasselgrep/pull/22.patch'
+ 'quasselgrep-py3.7.patch::https://patch-diff.githubusercontent.com/raw/fish-face/quasselgrep/pull/26.patch')
+sha256sums=('SKIP'
+ '398faf15be411720f2859453a3c16ddbe8cb708c35899dfbf694dbeff6ad6598'
+ 'e45de4a40ef349d1c53442c69d1c5f139d1d3ec5e5d4d807e9defec4487cb8c5')
pkgver() {
cd $_pkgname
@@ -22,6 +26,13 @@ pkgver() {
printf 'r%s.g%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd $_pkgname
+
+ patch -Np1 < ../quasselgrep-timestamps.patch
+ patch -Np1 < ../quasselgrep-py3.7.patch
+}
+
package() {
cd $_pkgname