summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOtto Sabart2021-04-14 00:34:49 +0200
committerOtto Sabart2021-04-14 00:34:49 +0200
commit0623830a01d3cbf7ad9ce1cfde6750fdc793c78f (patch)
tree386df000a1fc3ece8a2f405414d5b18afb766afe /PKGBUILD
parent752b1fd61af6dc2a7b100228ec2b3f24b15d38d9 (diff)
downloadaur-0623830a01d3cbf7ad9ce1cfde6750fdc793c78f.tar.gz
pkgbuild: add the rest of the packages
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 37 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41398e981e48..dd934f41014b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,7 @@
# Ref.: https://github.com/QubesOS/qubes-core-agent-linux/tree/master/archlinux
-#pkgname=(qubes-vm-core qubes-vm-networking qubes-vm-keyring)
-pkgname=(qubes-vm-core)
+pkgname=(qubes-vm-core qubes-vm-networking qubes-vm-keyring)
_gitname=${pkgname%-git*}
pkgver=4.0.61
pkgrel=1
@@ -122,3 +121,39 @@ EOF
# Archlinux packaging guidelines: /var/run is a symlink to a tmpfs. Don't create it
rm -r "$pkgdir/var/run"
}
+
+
+#This package provides:
+# * proxy service used by TemplateVMs to download updates
+# * qubes-firewall service (FirewallVM)
+#
+#Integration of NetworkManager for Qubes VM:
+# * make connections config persistent
+# * adjust DNS redirections when needed
+# * show/hide NetworkManager applet icon
+#
+package_qubes-vm-networking() {
+ pkgdesc="Qubes OS tools allowing to use a Qubes VM as a NetVM/ProxyVM"
+ depends=(qubes-vm-core qubes-vm-utils python ethtool net-tools
+ qubes-db-vm networkmanager iptables tinyproxy nftables
+ conntrack-tools
+ )
+ install=PKGBUILD-networking.install
+
+ cd "${srcdir}/${_gitname}/"
+
+ # shellcheck disable=SC2154
+ make install-netvm DESTDIR="$pkgdir" SBINDIR=/usr/bin LIBDIR=/usr/lib SYSLIBDIR=/usr/lib SYSTEM_DROPIN_DIR=/usr/lib/systemd/system USER_DROPIN_DIR=/usr/lib/systemd/user DIST=archlinux
+}
+
+
+package_qubes-vm-keyring() {
+ pkgdesc="Qubes OS Binary Repository Activation package and Keyring"
+ install=PKGBUILD-keyring.install
+
+ # Install keyring (will be activated through the .install file)
+ install -dm755 "${pkgdir}/usr/share/pacman/keyrings/"
+ install -m0644 PKGBUILD-keyring-keys "${pkgdir}/usr/share/pacman/keyrings/qubesos-vm.gpg"
+ install -m0644 PKGBUILD-keyring-trusted "${pkgdir}/usr/share/pacman/keyrings/qubesos-vm-trusted"
+ install -m0644 PKGBUILD-keyring-revoked "${pkgdir}/usr/share/pacman/keyrings/qubesos-vm-revoked"
+}