summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZes4null2023-05-22 13:50:51 +0800
committerZes4null2023-05-22 13:50:51 +0800
commit1a6979cfb6ca7d2b188f50eeaa0db5e1a1abfa56 (patch)
tree61feb7c9731b68ee94842157f1e3210d94a0373e /PKGBUILD
parent91f8a9948c7a823206c2e2ddf90065806349ad2b (diff)
downloadaur-1a6979cfb6ca7d2b188f50eeaa0db5e1a1abfa56.tar.gz
update to 1.0.2, enable parallel building
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2ef01d141b01..1a5e2f2c7df4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,12 @@
# Contributor: Philip <philip1731 protonmail ch>
pkgname=qucs-s
-pkgver=1.0.1
+pkgver=1.0.2
pkgrel=1
pkgdesc="A spin-off of Qucs that supports other free SPICE circuit simulators like ngspice with the same Qucs GUI"
arch=('x86_64' 'i686')
url="https://ra3xdh.github.io"
license=('GPL')
-options=(!makeflags)
depends=('qt6-svg' 'ngspice')
makedepends=('cmake' 'qt6-tools')
optdepends=('ngspice: recommended simulation backend'
@@ -17,17 +16,17 @@ optdepends=('ngspice: recommended simulation backend'
'spiceopus: a general purpose simulation backend for optimization loops'
)
source=(https://github.com/ra3xdh/qucs_s/releases/download/$pkgver/$pkgname-$pkgver.tar.gz)
-sha256sums=('6ba278a91fab96d6a3d2f17d590997725146f415030217bc3e7f3cf2c5f7c14b')
+sha256sums=('9ad700c4d83f08ae0a8a8c8b3f02e13d4b0b96082cd2cc877cbc036df31d1abb')
build() {
+ export QT_DIR=/usr/lib/cmake/Qt6/
cd $srcdir/$pkgname-$pkgver
mkdir -p builddir
cd builddir
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DWITH_QT6=ON \
..
- make
+ make -j$(nproc)
}
package() {