summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwatermelon2022-11-15 10:12:38 +0800
committerwatermelon2022-11-15 10:12:38 +0800
commit8fdef11e746afd955eb9c910ad4644d87fa588c5 (patch)
tree4c0b2c24ada3b6201bea50f0e1c36a46791761ee /PKGBUILD
parentd216f428b8ace527005be48c31f00fed4cb06a1a (diff)
downloadaur-8fdef11e746afd955eb9c910ad4644d87fa588c5.tar.gz
1.0.0 updated
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1d38f1bf4c28..c73592199863 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,22 @@
# Contributor: Philip <philip1731 protonmail ch>
pkgname=qucs-s
-pkgver=0.0.24
+pkgver=1.0.0
pkgrel=1
pkgdesc="A spin-off of Qucs that supports other free SPICE circuit simulators like ngspice with the same Qucs GUI"
arch=('x86_64' 'i686')
url="https://ra3xdh.github.io"
license=('GPL')
options=(!makeflags)
-depends=('qt5-base')
-makedepends=('cmake' 'autoconf' 'automake' 'perl-gd' 'perl-xml-libxml' 'gperf' 'libtool' 'flex' 'bison' 'qt5-tools' 'qt5-script' 'qt5-svg')
+depends=('qt5-svg')
+makedepends=('cmake' 'qt5-tools')
optdepends=('ngspice: recommended simulation backend'
'qucs: for Qucsator simulation backend'
- 'freehdl: to permit digital circuit simulation'
- 'asco: to enable circuit optimization'
+ 'xyce-serial: a SPICE-compatible simulation backend'
+ 'spiceopus: a general purpose simulation backend for optimization loops'
)
source=(https://github.com/ra3xdh/qucs_s/releases/download/$pkgver/$pkgname-$pkgver.tar.gz)
-sha256sums=('ba7cf6fb06babbddcbb7d4eae0437df4e36346b7cc39a84af62f1643d7e8f296')
+sha256sums=('fc8d446a52dd4730ccba021df8f8a5331d22e1a26edd5d853c2d16518d32953f')
build() {
cd $srcdir/$pkgname-$pkgver