summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwatermelon2023-02-05 22:23:36 +0800
committerwatermelon2023-02-05 22:23:36 +0800
commit91f8a9948c7a823206c2e2ddf90065806349ad2b (patch)
tree01dd6d73ee2ef8111f135006dfc7650898b89ef3 /PKGBUILD
parent8fdef11e746afd955eb9c910ad4644d87fa588c5 (diff)
downloadaur-91f8a9948c7a823206c2e2ddf90065806349ad2b.tar.gz
1.0.1 released; Switch to QT6.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c73592199863..2ef01d141b01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,31 @@
# Contributor: Philip <philip1731 protonmail ch>
pkgname=qucs-s
-pkgver=1.0.0
+pkgver=1.0.1
pkgrel=1
pkgdesc="A spin-off of Qucs that supports other free SPICE circuit simulators like ngspice with the same Qucs GUI"
arch=('x86_64' 'i686')
url="https://ra3xdh.github.io"
license=('GPL')
options=(!makeflags)
-depends=('qt5-svg')
-makedepends=('cmake' 'qt5-tools')
+depends=('qt6-svg' 'ngspice')
+makedepends=('cmake' 'qt6-tools')
optdepends=('ngspice: recommended simulation backend'
'qucs: for Qucsator simulation backend'
'xyce-serial: a SPICE-compatible simulation backend'
'spiceopus: a general purpose simulation backend for optimization loops'
)
source=(https://github.com/ra3xdh/qucs_s/releases/download/$pkgver/$pkgname-$pkgver.tar.gz)
-sha256sums=('fc8d446a52dd4730ccba021df8f8a5331d22e1a26edd5d853c2d16518d32953f')
+sha256sums=('6ba278a91fab96d6a3d2f17d590997725146f415030217bc3e7f3cf2c5f7c14b')
build() {
cd $srcdir/$pkgname-$pkgver
mkdir -p builddir
cd builddir
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWITH_QT6=ON \
+ ..
make
}