summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastian Yesid Tabares Amaya2018-12-04 11:59:04 -0500
committerSebastian Yesid Tabares Amaya2018-12-04 11:59:04 -0500
commitf77f09bcf5fddfdced2fbc4814e8c333d5c058ff (patch)
tree57007ecc1c03d737b31c516469c9b2311715ee53 /PKGBUILD
parent1794513d6c1f0bae234d34e21efd2a01961b2e1f (diff)
downloadaur-f77f09bcf5fddfdced2fbc4814e8c333d5c058ff.tar.gz
Upgrade to v0.0.21
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99a7711d903e..0a972a72a902 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: sytabaresa <sytabaresa@gmail.com>
pkgname=qucs-s
-_pkgname=qucs
-pkgver=0.0.19S
+pkgver=0.0.21
pkgrel=1
pkgdesc="A spin-off of Qucs that supports other free SPICE circuit simulators like ngspice with the same Qucs GUI"
arch=('x86_64' 'i686')
@@ -12,15 +11,15 @@ options=(!makeflags)
depends=('qt4')
makedepends=('cmake' 'autoconf' 'automake' 'perl-gd' 'perl-xml-libxml' 'gperf' 'libtool' 'flex' 'bison')
optdepends=('ngspice: recommended simulation backend'
- 'qucs: for Qucsator simulation backend'
- 'freehdl: to permit digital circuit simulation'
+ 'qucs: for Qucsator simulation backend'
+ 'freehdl: to permit digital circuit simulation'
'asco: to enable circuit optimization'
- )
-source=(https://github.com/ra3xdh/$_pkgname/releases/download/$pkgver/$_pkgname-$pkgver.tar.gz)
-sha1sums=('6c7a527886592dbdc6a061fc03fb0d6101f6a70a')
+ )
+source=(https://github.com/ra3xdh/qucs_s/releases/download/$pkgver/$pkgname-$pkgver.tar.gz)
+sha1sums=('7879565da266ce6562db274d3298bf7bef8c389f')
build() {
- cd $srcdir/qucs-$pkgver
+ cd $srcdir/$pkgname-$pkgver
mkdir builddir
cd builddir
cmake -DCMAKE_INSTALL_PREFIX=/usr ..
@@ -28,7 +27,6 @@ build() {
}
package() {
- cd $srcdir/qucs-$pkgver/builddir
+ cd $srcdir/$pkgname-$pkgver/builddir
make DESTDIR="$pkgdir" install
-}
-
+} \ No newline at end of file