summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2020-11-09 11:14:56 -0700
committerMark Wagie2020-11-09 11:14:56 -0700
commit59d6960ff597a75556a7a6160ece855b27399aa7 (patch)
tree3ace8f925cb7ee9331825ec37865cf017db05e42 /PKGBUILD
downloadaur-59d6960ff597a75556a7a6160ece855b27399aa7.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83c6bfa932af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=quick-lookup
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Simple GTK dictionary application powered by Wiktionary"
+arch=('any')
+url="https://github.com/johnfactotum/quick-lookup"
+license=('GPL3')
+depends=('gjs' 'webkit2gtk')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('b292de88339e4f4cffbcd15701933c33d395fc6f877cd2176932a3ae70771355')
+
+package() {
+ _name='com.github.johnfactotum.QuickLookup'
+
+ cd "$pkgname-$pkgver"
+ install -Dm755 "$pkgname.js" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$_name.desktop" -t "$pkgdir/usr/share/applications"
+ install -Dm644 "$_name.svg" -t "$pkgdir/usr/share/icons/hicolor/scalable/apps"
+ install -Dm644 "$_name-symbolic.svg" -t \
+ "$pkgdir/usr/share/icons/hicolor/symbolic/apps"
+ install -Dm644 "$_name.gschema.xml" -t "$pkgdir/usr/share/glib-2.0/schemas"
+}