summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryjun1232020-09-08 16:51:24 +0800
committeryjun1232020-09-08 16:51:24 +0800
commitf0ae45c9b7d768a677904bb483b29187c2464bce (patch)
tree61fbac634287ca67b7fea11f0cbda2fe5ec90ab1 /PKGBUILD
parent45eeccd5b2598fc7a2072f51fee8222a3a952d05 (diff)
downloadaur-f0ae45c9b7d768a677904bb483b29187c2464bce.tar.gz
fixed build error
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8949b84941b6..d0449cf83f8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=quickcut-git
_pkgname=${pkgname%-git}
_gitname=QuickCut
pkgver=v1.6.9.r1.g3db7bef
-pkgrel=1
+pkgrel=2
pkgdesc="Your most handy video processing software."
arch=('x86_64' 'i686')
url="https://github.com/HaujetZhao/QuickCut"
@@ -38,13 +38,19 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ cd $_gitname
+
+ python setup.py build
+}
+
package() {
cd $_gitname
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
# icon
- icotool -x QuickCut/QuickCut/icon.ico
+ icotool -x QuickCut/icon.ico
install -Dm644 icon_*_32x32x32.png ${pkgdir}/usr/share/pixmaps/${_pkgname}.png
# desktop entry