summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoratomlong2021-10-23 15:59:55 +0800
committeratomlong2021-10-23 15:59:55 +0800
commit0f8d2c336645654211bb6a37411fe62de943edfd (patch)
tree94c89079ca28fdd01aa70d6fcd983c40414cd339 /PKGBUILD
parent0a0e55329a6c64f5daa3bad3513575b106c10e90 (diff)
downloadaur-0f8d2c336645654211bb6a37411fe62de943edfd.tar.gz
change pkgname to quickjspp-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0db39312fc18..b1780fb07389 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,31 @@
# Maintainer: Atom Long <atom.long@hotmail.com>
-pkgname=quickjspp
+pkgname=quickjspp-git
pkgver=20210913
-pkgrel=2
+pkgrel=3
pkgdesc='QuickJS C++ wrapper'
url='https://github.com/ftk/quickjspp'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
license=('CC0')
-source=("${pkgname}::git+${url}.git")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+${url}.git")
sha256sums=('SKIP')
makedepends=('cmake' 'git')
pkgver() {
- cd ${pkgname}
+ cd ${pkgname%-git}
git show -s --format="%ci" HEAD | sed -e 's/-//g' -e 's/ .*//'
}
build() {
- cd ${pkgname}
+ cd ${pkgname%-git}
cmake -DCMAKE_BUILD_TYPE=Release .
make quickjs
}
package() {
- cd ${pkgname}
+ cd ${pkgname%-git}
install -Dm644 quickjs/libquickjs.a -t ${pkgdir}/usr/lib/
install -Dm644 quickjs/quickjs.h quickjs/quickjs-libc.h -t ${pkgdir}/usr/include/quickjs/
install -m644 quickjspp.hpp ${pkgdir}/usr/include/