summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordeepjyoti302019-12-14 12:14:11 +0530
committerdeepjyoti302019-12-14 12:14:11 +0530
commit9a2ac60a906eef7729c71e4be12a4bf9ee07ee1c (patch)
tree4cca9c86721c6571f9c6e28447c2107a61662a87 /PKGBUILD
parentfc534e79ed042afead4ee8fc1a78455515df4878 (diff)
downloadaur-9a2ac60a906eef7729c71e4be12a4bf9ee07ee1c.tar.gz
version: 0.0.2 release.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0db78ed04099..dad8431c8797 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Deepjyoti <deep.barman30@gmail.com>
pkgname=quickwall
-pkgver=0.0.1
-pkgrel=4
+pkgver=0.0.2
+pkgrel=0
pkgdesc="Quickly set wallpapers from CLI directly from Unsplash."
arch=("any")
url="https://github.com/deepjyoti30/QuickWall"
@@ -9,6 +9,9 @@ license=('MIT')
depends=(
"python>=3.6"
"nitrogen>=1.6.1"
+ "python-pywal"
+ "downloader-cli"
+ "python-requests"
)
makedepends=("git" "python-setuptools")
optdepends=()
@@ -19,18 +22,18 @@ backup=()
options=()
install=
changelog=
-source=("https://github.com/deepjyoti30/QuickWall/archive/0.0.1-4.tar.gz")
+source=("https://github.com/deepjyoti30/QuickWall/archive/0.0.2.tar.gz")
noextract=()
md5sums=("SKIP")
validpgpkeys=()
build() {
- cd "QuickWall-${pkgver}-${pkgrel}"
+ cd "QuickWall-${pkgver}"
python setup.py build
}
package() {
- cd "QuickWall-${pkgver}-${pkgrel}"
+ cd "QuickWall-${pkgver}"
python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1 --skip-build
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}