summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDonald Carr2017-06-14 13:11:41 -0700
committerDonald Carr2017-06-14 15:42:21 -0700
commitc1ed320d5dadd475ab917b1c693db6f5092737bc (patch)
treec1ddc532cad73524a3b18057178cd75eb766e09b /PKGBUILD
parent1d726f5b3145a252faa9cff26a05afcdde3520b2 (diff)
downloadaur-c1ed320d5dadd475ab917b1c693db6f5092737bc.tar.gz
Move to tagged based versioning
Change-Id: I221489fc5f422dff57a616bc285bbb6e51b7cae0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a279f96d31a3..cb69ecb8b517 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ if [[ -n "$_piver" ]]; then
fi
pkgname="quint"
-pkgver=0.0.1
+pkgver=.0.1
pkgrel=1
pkgdesc="Live coding demo for the Raspberry Pi"
arch=("any")
@@ -25,6 +25,11 @@ source=("git://github.com/sirspudd/${pkgname}.git")
sha256sums=("SKIP")
options=('!strip')
+pkgver() {
+ cd ${srcdir}/${pkgname}
+ git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
local repo_src=${srcdir}/${pkgname}