summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDct Mei2020-08-07 18:03:02 +0800
committerDct Mei2020-08-07 18:03:02 +0800
commit0bf02d0ccf0e1a3bc52bf5d82ffacb2291668da1 (patch)
tree76a41c22d25e2f2269a67e2a0964b2f9e12683df /PKGBUILD
downloadaur-0bf02d0ccf0e1a3bc52bf5d82ffacb2291668da1.tar.gz
feat: v2.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3bfaa3827bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Dct Mei <dctxmei@gmail.com>
+
+pkgname=qv2ray-plugin-command
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Qv2ray Plugin: Command"
+arch=('x86_64')
+url="https://github.com/Qv2ray/QvPlugin-Command"
+license=('GPL3')
+depends=('qv2ray')
+makedepends=('cmake' 'git' 'ninja')
+groups=('qv2ray-plugin')
+source=("$pkgname-$pkgver::git+$url.git#tag=v$pkgver")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ git submodule update --init
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ mkdir -p build && cd build
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -GNinja
+ ninja
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/build/"
+ install -Dm 644 libQvCommandPlugin.so -t "$pkgdir/usr/share/qv2ray/plugins/"
+}