summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDuckSoft2020-11-15 19:22:24 +0800
committerDuckSoft2020-11-15 19:22:24 +0800
commit32a654afeb8caa28157723d7345497a588fe4219 (patch)
tree45a9c7cb8f0e1a3dd5321973b0ea5dcbd30ce4d8 /PKGBUILD
parent16e125a2903266f7dec2aa2da4906512ed9a52f9 (diff)
downloadaur-32a654afeb8caa28157723d7345497a588fe4219.tar.gz
fix install path problem
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 800287163b38..654dface5c8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: DuckSoft <realducksoft at gmail dot com>
pkgname=qv2ray-plugin-trojan-dev-git
_pkgname=qv2ray-plugin-trojan
-pkgver=20200429.r26.3305c41
+pkgver=20201101.r52.d646bc1
pkgrel=1
pkgdesc="Qv2ray Plugin: Trojan (Development Build)"
arch=('x86_64')
@@ -30,14 +30,15 @@ build() {
cd "$srcdir"/"$_pkgname"
mkdir -p build && cd build
cmake .. \
+ -DCMAKE_INSTALL_PREFIX="${pkgdir}"/usr \
-DCMAKE_BUILD_TYPE=Release \
-DFORCE_TCP_FASTOPEN=ON \
-GNinja
- ninja
+ cmake --build .
}
package() {
cd "$srcdir"/"$_pkgname"/build
- install -Dm644 libQvTrojanPlugin.so "$pkgdir"/usr/share/qv2ray/plugins/libQvTrojanPlugin.so
+ cmake --install .
# NOTE: This virtual dependency will be introduced after Qv2ray stablize its interface.
# depends+=(${_virtualdepends[@]})
}