summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSamLukeYes2022-01-13 18:10:04 +0800
committerSamLukeYes2022-01-13 18:10:04 +0800
commit623a0dfc0ea964cf5c3cce4a2e223944747de6f8 (patch)
tree9839af28219a7c5a8d58e3c15cef365a82f53abc /PKGBUILD
parentd9b00330249bd35f178685d0437f9342e7533908 (diff)
downloadaur-623a0dfc0ea964cf5c3cce4a2e223944747de6f8.tar.gz
add submodules to sources
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 39 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21e4d1a9bdfc..2bd535b572af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,56 @@
pkgname=qv2ray-v3
_tag=v3.0.0-rc1
pkgver=3.0.0rc1
-pkgrel=1
+pkgrel=4
pkgdesc="A cross platform connection manager for V2Ray and other backends."
arch=(x86_64)
url="https://github.com/Shadowsocks-NET/Qv2ray"
license=('GPL3')
depends=('grpc' 'hicolor-icon-theme' 'qt6-svg')
makedepends=('cmake' 'gcc' 'git' 'grpc-cli' 'make' 'ninja' 'qt6-declarative' 'qt6-tools' 'which')
-optdepends=('qt6-wayland: Wayland support (experimental)' 'v2ray: use packaged v2ray')
+optdepends=(
+ 'qt6-wayland: Wayland support (experimental)'
+ 'v2ray: Default V2Ray core'
+)
provides=('qv2ray')
conflicts=('qv2ray')
-source=("$pkgname::git+$url.git#tag=$_tag")
-sha512sums=('SKIP')
+source=(
+ "$pkgname::git+$url.git#tag=$_tag"
+ "git+https://github.com/itay-grudev/SingleApplication.git"
+ "git+https://github.com/cpeditor/QCodeEditor.git"
+ "git+https://github.com/danielsanfr/qt-qrcode.git"
+ "git+https://github.com/Shadowsocks-NET/Qv2rayBase.git"
+ "git+https://github.com/xiaokangwang/v2ray-core-1.git"
+ "git+https://github.com/moodyhunter/libRoutingA.git"
+ "git+https://github.com/fukuchi/libqrencode.git"
+ "git+https://github.com/libuv/libuv.git"
+ "git+https://github.com/skypjack/uvw.git"
+ "git+https://github.com/Shadowsocks-NET/Qv2rayBase-PluginInterface.git"
+)
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+patch_gitmodules() {
+ sed -i "s|https://github.com/.*/|${srcdir}/|;s|.git||" .gitmodules
+ git submodule update --init --force --remote
+}
prepare() {
cd "$srcdir/$pkgname"
- git submodule update --init --recursive
+ patch_gitmodules
+ cd "3rdparty/qt-qrcode"
+ patch_gitmodules
+ cd "../../src/Qv2rayBase"
+ patch_gitmodules
}
build() {