summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjustforlxz2023-11-23 17:43:08 +0800
committerjustforlxz2023-11-23 17:43:08 +0800
commite06ea18cfbcea31607fd8e0613eb7d7a2ba0a191 (patch)
tree83b4028a0873e2af50fc1ee3e4d1e2f9a289a9af /PKGBUILD
parentb452297d72d79cf6252be79d2caa17abe66f90c8 (diff)
downloadaur-e06ea18cfbcea31607fd8e0613eb7d7a2ba0a191.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8fb94fe82531..5d62bed6c20a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: justforlxz <justforlxz@gmail.com>
pkgname=qwlroots-git
-pkgver=r166.093e076
+pkgver=r224.16b01b7
pkgrel=1
pkgdesc='Qt and QML bindings for wlroots.'
arch=('x86_64' 'aarch64')
url="https://github.com/vioken/qwlroots"
license=('Apache' 'GPL2' 'GPL3' 'LGPL3')
depends=()
-makedepends=('git' 'wlroots-git')
+makedepends=('git' 'wlroots' 'ninja')
provides=('qwlroots')
source=("$pkgname::git+https://github.com/vioken/qwlroots")
sha512sums=('SKIP')
@@ -20,11 +20,11 @@ pkgver() {
build() {
cd $pkgname
- cmake -B . -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake -B . -G Ninja -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build .
}
package() {
cd $pkgname
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" ninja install
}