summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSpike292015-08-29 18:16:04 +0200
committerSpike292015-08-29 18:16:04 +0200
commit57ce1616c89d137223adfb6f1af2afadac715daf (patch)
treee0a8e1d56aed9afde371bac98722ece8f0e1ea47 /PKGBUILD
parentc30c233d54858da9a5ebb579203e6452f3a3436e (diff)
downloadaur-57ce1616c89d137223adfb6f1af2afadac715daf.tar.gz
Upstream release 0.9.0 ; use qt5 instead of qt4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e518e14d8d16..7ead2bbddda1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,28 +3,33 @@
# Contributor: Timothée Ravier <tim@siosm.fr>
pkgname='qxmpp'
-pkgver='0.8.3'
+pkgver='0.9.0'
pkgrel='1'
pkgdesc='An XMPP client library based on Qt & C++'
arch=('i686' 'x86_64')
url='https://github.com/qxmpp-project/qxmpp'
license=('LGPL2.1')
-depends=('qt4')
-optdepends=('speex: required to enable speex audio codec'
+depends=('qt5-base')
+optdepends=('doxygen: required to build the HTML documentation'
+ 'opus: required to enable opus audio codec'
+ 'speex: required to enable speex audio codec'
'libvpx: required to enable vpx video codec'
'libtheora: required to enable theora video codec')
-conflicts=('qxmpp-git' 'qxmpp-leechcraft-git' 'qxmpp-qt5' 'qxmpp-qt5-git')
+conflicts=('qxmpp-qt5')
source=("${url}/archive/v${pkgver}.tar.gz")
-sha1sums=('63828a91be14b68ec6f091b30a292d47eaf7a3c0')
+sha1sums=('8b73021378523c6d5134febc4db25985d11b0e68')
build() {
cd "$srcdir/$pkgname-$pkgver/"
[ -d build ] || mkdir build && cd build
- qmake-qt4 PREFIX=/usr ..
+
+ #In order to build the HTML documentation,
+ # add QXMPP_USE_DOXYGEN=1 to qmake arguments
- # In order to enable speex audio codec, vpx video codec or theora video codec,
- # add QXMPP_USE_SPEEX=1, QXMPP_USE_VPX=1 and QXMPP_USE_THEORA=1 to qmake arguments.
+ # In order to enable opus & speex audio codecs, and vpx & theora video codecs,
+ # add QXMPP_USE_OPUS=1, QXMPP_USE_SPEEX=1, QXMPP_USE_VPX=1 and QXMPP_USE_THEORA=1 to qmake arguments
+ qmake-qt5 PREFIX=/usr ..
make
}