summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJan Cholasta2014-05-14 13:29:14 +0200
committerJan Cholasta2014-05-14 13:29:14 +0200
commit7c70fcb8b1ab2cb5e0cf3e51e06fec060ce095dd (patch)
tree7947ba398bab54ae98f98f5c8956f1bd255cc1b7 /PKGBUILD
parent342b198a33f05e88895ee868bb14ad074a8cc8c6 (diff)
downloadaur-7c70fcb8b1ab2cb5e0cf3e51e06fec060ce095dd.tar.gz
Use git describe for pkgver in git packages.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d4c40eedde31..4d1359501554 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ if [[ "$CARCH" == x86_64 ]]; then
fi
pkgname=gzdoom-git
-pkgver=20130829
+pkgver=1.9pre.r605.gcd6d653
pkgrel=1
pkgdesc="Doom source port based on ZDoom with an OpenGL renderer (git version)."
arch=('i686' 'x86_64')
@@ -50,7 +50,8 @@ _libdir=/usr/lib/gzdoom
_sharedir=/usr/share/games/gzdoom
pkgver() {
- date +%Y%m%d
+ cd gzdoom
+ git describe --long --tags --match 'G*' | sed -r 's/^G//;s/([^-]*-g)/r\1/;s/-/./g'
}
prepare() {