summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-06-20 00:01:53 +0000
committerBioArchLinuxBot2023-06-20 00:01:53 +0000
commit002149fb1bd6c201cac2059ecd6bd21a86a27bf8 (patch)
tree030464d1c0bfb70f4d9d591d9860664232ed4ec2 /PKGBUILD
parentc2b4e78a4a1d69da8c2337b543197ff0f3408dcb (diff)
downloadaur-r-abind.tar.gz
[lilac] updated to 1.4.5-10
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 19 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 065572c38ce1..fdfaf071afd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,31 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Taekyung Kim <Taekyung.Kim.Maths@gmail.com>
# Contributor: Alex Branham <branham@utexas.edu>
-_cranname=abind
-_cranver=1.4-5
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=1
+_pkgname=abind
+_pkgver=1.4-5
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//[:-]/.}
+pkgrel=10
pkgdesc="Combine Multidimensional Arrays"
arch=(any)
-url="https://cran.r-project.org/package=${_cranname}"
-license=(LGPL2 LGPL2.1 LGPL3)
-depends=('r>=1.5.0')
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+url="https://cran.r-project.org/package=${_pkgname}"
+license=(LGPL)
+depends=(
+ r
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('136f981e1c4f618b64a87faaa7797c97')
sha256sums=('3a3ace5afbcb86e56889efcebf3bf5c3bb042a282ba7cc4412d450bb246a3f2c')
build() {
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
-
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}