summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 01:15:34 +0800
committerSukanka2022-06-06 01:15:34 +0800
commitcf3b66729c3a8e73d0e4b936b9bffefb9cd8c2fc (patch)
treeedb33afb59da722d9e2cb1e6fd2d90f416f101de /PKGBUILD
downloadaur-cf3b66729c3a8e73d0e4b936b9bffefb9cd8c2fc.tar.gz
add r-affycoretools
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..269cb0215797
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=affycoretools
+_pkgver=1.68.1
+pkgname=r-${_pkgname,,}
+pkgver=1.68.1
+pkgrel=1
+pkgdesc='Functions useful for those doing repetitive analyses with Affymetrix GeneChips'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-affy
+ r-annotationdbi
+ r-biobase
+ r-biocgenerics
+ r-dbi
+ r-edger
+ r-gcrma
+ r-ggplot2
+ r-glimma
+ r-gostats
+ r-gplots
+ r-hwriter
+ r-limma
+ r-oligoclasses
+ r-reportingtools
+ r-rsqlite
+ r-s4vectors
+ r-xtable
+)
+optdepends=(
+ r-affydata
+ r-biocstyle
+ r-hgfocuscdf
+ r-hgu95av2.db
+ r-knitr
+ r-rgl
+ r-rmarkdown
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('9c0f1ab7e121e6655ce831f70b188ec006ff5fc204f3b8c649af5e593c24a617')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: