summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 01:25:49 +0800
committerSukanka2022-06-06 01:25:49 +0800
commit61ea415a7052f09b2d888fd04b3dcc5342cd79ca (patch)
treee29dca75b23b1f8dcb0060b425f46c5f9cf5e283 /PKGBUILD
downloadaur-61ea415a7052f09b2d888fd04b3dcc5342cd79ca.tar.gz
add r-allelicimbalance
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6f29f38bf87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=AllelicImbalance
+_pkgver=1.34.0
+pkgname=r-${_pkgname,,}
+pkgver=1.34.0
+pkgrel=1
+pkgdesc='Investigates Allele Specific Expression'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-annotationdbi
+ r-biocgenerics
+ r-biostrings
+ r-bsgenome
+ r-genomeinfodb
+ r-genomicalignments
+ r-genomicfeatures
+ r-genomicranges
+ r-gridextra
+ r-gviz
+ r-iranges
+ r-latticeextra
+ r-rsamtools
+ r-s4vectors
+ r-seqinr
+ r-summarizedexperiment
+ r-variantannotation
+)
+optdepends=(
+ r-biocstyle
+ r-knitr
+ r-org.hs.eg.db
+ r-rmarkdown
+ r-snplocs.hsapiens.dbsnp144.grch37
+ r-testthat
+ r-txdb.hsapiens.ucsc.hg19.knowngene
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('5fd4b8c0463924f48128dd4e1b5f2ee8410ad57d91e297e15aa7f3f93b689d70')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: