summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 01:47:13 +0800
committerSukanka2022-06-06 01:47:13 +0800
commitba2afc65a9b49fc23a2093d1601e67132b17136e (patch)
tree38a6c1747ae686782a5cef3fc89695967ab06870 /PKGBUILD
downloadaur-ba2afc65a9b49fc23a2093d1601e67132b17136e.tar.gz
add r-aroma.light
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..219ef95a9862
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=aroma.light
+_pkgver=3.26.0
+pkgname=r-${_pkgname,,}
+pkgver=3.26.0
+pkgrel=3
+pkgdesc='Light-Weight Methods for Normalization and Visualization of Microarray Data using Only Basic R Data Types'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-matrixstats
+ r-r.methodss3
+ r-r.oo
+ r-r.utils
+)
+optdepends=(
+ r-princurve
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('da6fd263bcf8a66b8b6f09bc16a1360fc5c92c4c415794d22b4038bd79da8088')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: