diff options
author | BioArchLinuxBot | 2024-02-14 12:05:23 +0000 |
---|---|---|
committer | BioArchLinuxBot | 2024-02-14 12:05:23 +0000 |
commit | 4f79eee5aa8c32f0288d8b24df7707c28385f728 (patch) | |
tree | 3fb7e5069f7e80b0a80107eb43ec9da14d9b511b /PKGBUILD | |
parent | 91c901b72cbeb8e5f07fe3882e7567b235b34506 (diff) | |
download | aur-4f79eee5aa8c32f0288d8b24df7707c28385f728.tar.gz |
[lilac] updated to 14.0.0.2-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 58 |
1 files changed, 41 insertions, 17 deletions
@@ -1,21 +1,19 @@ -# system requirements: C++11; for AWS S3 support on Linux, libcurl andopenssl (optional) -# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net> +# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com> +# Contributor: Guoyi Zhang <guoyizhang at malacology dot net> _pkgname=arrow _pkgver=14.0.0.2 pkgname=r-${_pkgname,,} -pkgver=14.0.0.2 -pkgrel=1 +pkgver=${_pkgver//-/.} +pkgrel=2 pkgdesc="Integration to 'Apache' 'Arrow'" -arch=('x86_64') -url="https://cran.r-project.org/package=${_pkgname}" -license=('Apache') +arch=(x86_64) +url="https://cran.r-project.org/package=$_pkgname" +license=(Apache) depends=( - r arrow r-assertthat r-bit64 - r-cpp11 r-glue r-purrr r-r6 @@ -23,11 +21,23 @@ depends=( r-tidyselect r-vctrs ) +makedepends=( + r-cpp11 +) +checkdepends=( + r-blob + r-curl + r-dplyr + r-hms + r-lubridate + r-reticulate + r-stringr + r-testthat +) optdepends=( - libcurl-compat - openssl r-blob r-cli + r-curl r-dbi r-dbplyr r-decor @@ -50,15 +60,29 @@ optdepends=( r-tzdb r-withr ) -source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz") -sha256sums=('7138a52d66f1b94ec31c25e8929d6f92b1640df852a10817600a82ab68ba8ab7') +source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz" + "fix-build.patch") +md5sums=('84cefe34da6af43984b308ca2a57d7bd' + '3c7ea1780d1a7eff30d0243e161534ce') +b2sums=('5d234175981bde6b094593856e8286048ca05308eb00d591c96a68826e43e78c2cf8d594316c50946b374e6e872ff065aeb191c36d0ba0b1104f31cc94ae6102' + '1926311b6ec30259adcfcfa94cfff8cbe55bf3a87c324112fba5e601bd1daa404efd79e7b78a21eb72982686e12614f33c17421a59cc07858734d58676edd70c') + +prepare() { + # fix build with system arrow, skip failing tests + patch -Np1 -i fix-build.patch +} build() { - R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}" + mkdir build + R CMD INSTALL -l build "$_pkgname" +} + +check() { + cd "$_pkgname/tests" + R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R } package() { - install -dm0755 "${pkgdir}/usr/lib/R/library" - cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library" + install -d "$pkgdir/usr/lib/R/library" + cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library" } -# vim:set ts=2 sw=2 et: |