summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 01:54:05 +0800
committerSukanka2022-06-06 01:54:05 +0800
commit18a4c6100e729b15309f258f5c8a24815e0ada51 (patch)
treee7ca8e684d52a0e694cd5e5759dc63ee3cee53b7 /PKGBUILD
downloadaur-18a4c6100e729b15309f258f5c8a24815e0ada51.tar.gz
add r-ashr
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e5b83eb119e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=ashr
+_pkgver=2.2-54
+pkgname=r-${_pkgname,,}
+pkgver=2.2.54
+pkgrel=3
+pkgdesc='Methods for Adaptive Shrinkage, using Empirical Bayes'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-etrunct
+ r-invgamma
+ r-mixsqp
+ r-rcpp
+ r-squarem
+ r-truncnorm
+)
+optdepends=(
+ r-ggplot2
+ r-knitr
+ r-rebayes
+ r-rmarkdown
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('ea39ad1d4fcb2f7a331c6629f8d69d1038abd1271be3338ef1de307bd5d0fd9c')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: