summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 02:19:16 +0800
committerSukanka2022-06-06 02:19:16 +0800
commit783d8cbf6f5e9e1df039e26019d262fd93b76800 (patch)
tree8eb4879caf378db6dbfc62c200dcaaf6a1e32a12 /PKGBUILD
downloadaur-783d8cbf6f5e9e1df039e26019d262fd93b76800.tar.gz
add r-basics
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8eefccaad66b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# system requirements: C++11
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=BASiCS
+_pkgver=2.8.0
+pkgname=r-${_pkgname,,}
+pkgver=2.8.0
+pkgrel=1
+pkgdesc='Bayesian Analysis of Single-Cell Sequencing data'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-assertthat
+ r-biobase
+ r-biocgenerics
+ r-biocparallel
+ r-coda
+ r-cowplot
+ r-ggextra
+ r-ggplot2
+ r-hexbin
+ r-matrixstats
+ r-rcpp
+ r-rcpparmadillo
+ r-reshape2
+ r-s4vectors
+ r-scran
+ r-scuttle
+ r-singlecellexperiment
+ r-summarizedexperiment
+ r-viridis
+ gcc
+)
+optdepends=(
+ r-biocstyle
+ r-knitr
+ r-magick
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('d6c603246c5b3c641d4d5aef0d2d0285ff2e46246fc8ab94880c8bcd7a20e019')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: