summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 02:20:27 +0800
committerSukanka2022-06-06 02:20:27 +0800
commita65a3370c8aaf9fd1ab39702a8fec6bf3993c8b8 (patch)
treed5a13956f6634fb3aa07eab795c787edd8415baf /PKGBUILD
downloadaur-a65a3370c8aaf9fd1ab39702a8fec6bf3993c8b8.tar.gz
add r-basilisk
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bccf8af57cdb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=basilisk
+_pkgver=1.8.0
+pkgname=r-${_pkgname,,}
+pkgver=1.8.0
+pkgrel=1
+pkgdesc='Freezing Python Dependencies Inside Bioconductor Packages'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-basilisk.utils
+ r-dir.expiry
+ r-reticulate
+)
+optdepends=(
+ r-biocstyle
+ r-callr
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('f07b0f309c697e74baa563e927de2b86b7a90b7c9f7856dfc537f3a410e620dd')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: