summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2019-02-06 19:29:18 +0000
committerGrey Christoforo2019-02-06 19:29:18 +0000
commitc8bd7cf25a839ec68626aa96fc6da7c7c6002ffe (patch)
treeaa56e7123de5f8d496d4143c97f6468f541b2584 /PKGBUILD
parentd31d5020f00c36061f9439169ac395188118b9a2 (diff)
downloadaur-c8bd7cf25a839ec68626aa96fc6da7c7c6002ffe.tar.gz
version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac8d4a9c01c8..99b0e1c73442 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
-# Contributor: Sauliusl <luksaulius at gmail>
+# Contributor: Grey Christoforo <first name at last name dot net>
pkgname=r-biocgenerics
-pkgver=0.20.0
+_bc_name=BiocGenerics
+pkgver=0.28.0
pkgrel=1
pkgdesc="S4 generic functions needed by many Bioconductor packages."
-arch=('i686' 'x86_64')
url="https://bioconductor.org/packages/release/bioc/html/BiocGenerics.html"
+arch=("x86_64")
license=('Artistic-2.0')
depends=('r')
-source=("https://bioconductor.org/packages/release/bioc/src/contrib/BiocGenerics_${pkgver}.tar.gz")
-sha1sums=('aa9bd7cc80c8af430badee6b16fc1dd4b91afe6c')
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_bc_name}_${pkgver}.tar.gz")
+sha1sums=('3af3313dbc08cfbe94f70fdd0313bc45236e20da')
package() {
mkdir -p $pkgdir/usr/lib/R/library
cd $srcdir
- R CMD INSTALL -l $pkgdir/usr/lib/R/library ./BiocGenerics
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_bc_name}
}