summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2019-02-08 17:53:16 +0000
committerGrey Christoforo2019-02-08 17:53:16 +0000
commitc0c281a6fdb59d26b7377e6c2b53c92fd06da54a (patch)
tree414f3c4b94efaec616c97f484c3a03f4beb2d1fd /PKGBUILD
downloadaur-c0c281a6fdb59d26b7377e6c2b53c92fd06da54a.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1769d179e84b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Contributor: Grey Christoforo <first name at last name dot net>
+pkgname=r-biostrings
+_bc_name=Biostrings
+pkgver=2.50.2
+pkgrel=1
+pkgdesc="Efficient manipulation of biological strings"
+url="https://bioconductor.org/packages/release/bioc/html/${_bc_name}.html"
+arch=("x86_64")
+license=('Artistic-2.0')
+depends=('r' 'r-biocgenerics' 'r-s4vectors' 'r-iranges' 'r-xvector')
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_bc_name}_${pkgver}.tar.gz")
+sha1sums=('970278dcf63fe93f82f85caa76a747a597dad4e3')
+
+package() {
+ mkdir -p $pkgdir/usr/lib/R/library
+ cd $srcdir
+
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_bc_name}
+}