summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaha6622020-03-01 21:53:48 -0500
committerhaha6622020-03-01 21:53:48 -0500
commit821e6b35bc7cb022267e8e28fa29e641f824db04 (patch)
treee2dc64b110926a78e8b8f3cc3eef4ab1701aceec /PKGBUILD
downloadaur-821e6b35bc7cb022267e8e28fa29e641f824db04.tar.gz
Initialize
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..160150976c8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: haha662 <haha662 at outlook dot com>
+
+_cranname=bookdown
+_cranver=0.17
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="Authoring Books and Technical Documents with R Markdown"
+arch=("any")
+url="https://cran.r-project.org/package=${_cranname}"
+license=("GPL3")
+depends=("r" "pandoc>=1.17.2" "r-htmltools>=0.3.6" "r-knitr>=1.22" "r-rmarkdown>=1.12" "r-xfun>=0.6" "r-tinytex>=0.12")
+# makedepends=()
+optdepends=("r-htmlwidgets" "r-rstudioapi" "r-miniui" "r-rsconnect>=0.4.3" "r-servr>=0.13" "r-shiny" "r-testit>=0.9" "r-tufte" "r-webshot" )
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+sha256sums=("12102b200d4f0db106cafcb0bfde3a73b14ed7205661acfd1d818f6f9a7d6481")
+
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+}
+
+package() {
+ cd "${srcdir}"
+
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+}