summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorViktor Drobot2019-12-12 20:22:52 +0300
committerViktor Drobot2019-12-12 20:22:52 +0300
commit01f11bcc1276736e9b94030315c9ec0a5415e287 (patch)
tree144105efc629e190e647aeeb99cc08d24a80942d /PKGBUILD
parentb6cfa5758002e91162d7cb1048b20bf7749d0dd0 (diff)
downloadaur-01f11bcc1276736e9b94030315c9ec0a5415e287.tar.gz
Update 3.4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a6fc852472f0..8b06f639e14d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
_cranname=callr
-_cranver=3.3.2
+_cranver=3.4.0
pkgname=r-${_cranname}
pkgver=${_cranver//[:-]/.}
pkgrel=1
pkgdesc="Call R from R"
arch=('any')
url="https://cran.r-project.org/package=${_cranname}"
-license=('GPL3')
-depends=('r' 'r-processx' 'r-r6')
-optdepends=('r-cliapp' 'r-covr' 'r-crayon' 'r-pingr' 'r-ps' 'r-testthat' 'r-withr')
+license=('MIT')
+depends=('r' 'r-processx>=3.4.0' 'r-r6')
+optdepends=('r-cliapp' 'r-covr' 'r-crayon' 'r-fansi' 'r-knitr' 'r-pingr' 'r-ps' 'r-rmarkdown' 'r-rprojroot' 'r-spelling' 'r-testthat' 'r-tibble' 'r-withr')
source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-md5sums=('b9241e4c8c3b90d40734161680543374')
+md5sums=('79f2f27f1aadaac158e30b82d486ecdc')
build(){
cd "${srcdir}"
@@ -26,4 +26,3 @@ package() {
install -dm0755 "$pkgdir/usr/lib/R/library"
cp -a --no-preserve=ownership "$_cranname" "$pkgdir/usr/lib/R/library"
}
-