summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDrobot Viktor2019-09-30 17:40:31 +0300
committerDrobot Viktor2019-09-30 17:40:31 +0300
commitaafd15a013cff33c20d0fa3b5a2658983130c457 (patch)
tree8614b3d22a8008d736828b1b61bd5bb36364af51 /PKGBUILD
downloadaur-aafd15a013cff33c20d0fa3b5a2658983130c457.tar.gz
First release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b7ead2e740d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+_cranname=checkmate
+_cranver=1.9.4
+pkgname=r-${_cranname}
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="Fast and Versatile Argument Checks"
+arch=('i686' 'x86_64')
+url="https://cran.r-project.org/package=${_cranname}"
+license=('GPL3')
+depends=('r' 'r-backports' 'r-utils')
+optdepends=('r-r6' 'r-bit' 'r-fastmatch' 'r-devtools' 'r-ggplot2' 'r-knitr' 'r-magrittr' 'r-microbenchmark' 'r-rmarkdown' 'r-testthat' 'r-tibble')
+source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('cf2ea3fc2426cf6f7fd402322bf82b4b')
+
+build(){
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l $srcdir
+}
+
+package() {
+ cd "${srcdir}"
+
+ install -dm0755 "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "$_cranname" "$pkgdir/usr/lib/R/library"
+}