summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-07-22 12:06:30 +0000
committerBioArchLinuxBot2023-07-22 12:06:30 +0000
commit069f1cc9adb59d6a7ceeb4ada21fabbf77c3969e (patch)
treeff83959a2e9fa2bc072834354044dbb96c9e2113 /PKGBUILD
parent19d5cfc07ceb7f7cb6e9230859339b3f185db3cb (diff)
downloadaur-069f1cc9adb59d6a7ceeb4ada21fabbf77c3969e.tar.gz
[lilac] updated to 1.38.0-4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 28 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eb9966d813ef..099298b447d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,56 @@
-# system requirements: OpenBabel (>= 3.0.0) with headers(http://openbabel.org). Eigen3 with headers.
-# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=ChemmineOB
_pkgver=1.38.0
pkgname=r-${_pkgname,,}
-pkgver=1.38.0
-pkgrel=3
-pkgdesc='R interface to a subset of OpenBabel functionalities'
-arch=('x86_64')
+pkgver=${_pkgver//-/.}
+pkgrel=4
+pkgdesc="R interface to a subset of OpenBabel functionalities"
+arch=(x86_64)
url="https://bioconductor.org/packages/${_pkgname}"
-license=('custom')
+license=(Artistic2.0 GPL3)
depends=(
- r
- r-bh
+ openbabel
r-biocgenerics
r-rcpp
r-zlibbioc
- openbabel
+)
+makedepends=(
eigen
+ r-bh
+)
+checkdepends=(
+ r-chemminer
+ r-runit
)
optdepends=(
r-biocmanager
r-biocstyle
r-chemminer
- r-chemminer
r-knitr
r-knitrbootstrap
r-rmarkdown
r-runit
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('5d721ca0fa36f8b42fecca0ab4f98910')
sha256sums=('9115e25d3be94148fcc549b22af107c3fe0055569ac4e36ce161a203a8698450')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" Rscript --vanilla runTests.R
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
- install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
}
-# vim:set ts=2 sw=2 et: