summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 06:27:29 +0800
committerSukanka2022-06-06 06:27:29 +0800
commite8e0dd6c1f1cbd40c085e33fdf530fbb29fbf642 (patch)
tree72a5de53fee6a6b15cb37714dc0f99e8e72103d8 /PKGBUILD
downloadaur-e8e0dd6c1f1cbd40c085e33fdf530fbb29fbf642.tar.gz
add r-clipper
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38ff3b71ab46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=clipper
+_pkgver=1.36.0
+pkgname=r-${_pkgname,,}
+pkgver=1.36.0
+pkgrel=1
+pkgdesc='Gene Set Analysis Exploiting Pathway Topology'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('AGPL')
+depends=(
+ r
+ r-biobase
+ r-corpcor
+ r-graph
+ r-grbase
+ r-igraph
+ r-kegggraph
+ r-qpgraph
+ r-rbgl
+ r-rcpp
+)
+optdepends=(
+ r-all
+ r-biocgenerics
+ r-biocstyle
+ r-graphite
+ r-hgu95av2.db
+ r-mass
+ r-rcy3
+ r-runit
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('dcff9a08819835ebf5c1cdc6d260329ca7c77de94dea9d9c4741b7ab83e74ce8')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: