summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 06:37:43 +0800
committerSukanka2022-06-06 06:37:43 +0800
commitf3eae049409691c3f6bb799d39e8792dc5af2624 (patch)
tree2414b859481997ad3c83f99bdc3f211649309046 /PKGBUILD
downloadaur-f3eae049409691c3f6bb799d39e8792dc5af2624.tar.gz
add r-clvalid
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eaf89f7cb427
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=clValid
+_pkgver=0.7
+pkgname=r-${_pkgname,,}
+pkgver=0.7
+pkgrel=4
+pkgdesc='Validation of Clustering Results'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('LGPL')
+depends=(
+ r
+)
+optdepends=(
+ r-annotate
+ r-biobase
+ r-go.db
+ r-kohonen
+ r-mclust
+ r-moe430a.db
+ r-rankaggreg
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('037da469891462021eb177f9c9e18caefa8532f08c68fb576fae1668a1f451a1')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: