summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 06:54:48 +0800
committerSukanka2022-06-06 06:54:48 +0800
commit89dc71f4b868be029681826f3b1ed836dc39be36 (patch)
treec723a7f644e8bd719d952dcdc95740f48f0ae8d4 /PKGBUILD
downloadaur-89dc71f4b868be029681826f3b1ed836dc39be36.tar.gz
add r-combinepvalue
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c297a22c7678
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=CombinePValue
+_pkgver=1.0
+pkgname=r-${_pkgname,,}
+pkgver=1.0
+pkgrel=3
+pkgdesc='Combine a Vector of Correlated p-values'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('6243a2bef3ab0ef4ecd782ab969e2e6ca4d5ca5ad2daad641afa602bbe7f9656')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: